Jump to content

Recommended Posts

Все привет! есть проблемка при сетевом рендере компьютеры которые на КСЕОНАх 2670 128Gb Ram  отказываются рендере, стоют в какой-то стопор, закачивает 2ГБ оперативки и все. Компьютеры которые на I7 4770 32 GB  Ram работают без проблем. Подскажите где копать. Происходит следующее сначала загружается сцена потом грузится оболочка 3Дмакса потом окно Корона редер и когда пишет что начал парсинг сцены все стопор. Размер сцены 6000000 полигонов одни деревья  3DsMax 2016 / GrowFx 1.9.9 SP3 /  Backburner / Forestpack / Corona render.

Link to comment
Share on other sites

Приветствую!

 

Не знаю, смогу ли чем помочь или нет, так как у нас нет компьютеров на ксеонах, но вот прям совсем недавно разработчики Корона исправили какой-то баг.

Вот тут об этом было написано:

https://corona-renderer.com/forum/index.php/topic,15183.msg97809/topicseen.html#new

Link to comment
Share on other sites

Добрый день, Эдуард! В продолжении нашего вчерашнего разговора с проблемой сетевого рендера. Вот мы взяли с вашего сайта вот это дерево Matsu tree 1 от сюда https://exlevel.com/PlantsLibrary/#prettyPhotoи та же проблема на локальном компьютере рендер идет но только запускаем на рендер ферму все ступор , 3дмакс скушал 1,5 Гб памяти и все и компьютеры не чего не делают и не ругаются, Может что-то делаем по другому.

Link to comment
Share on other sites

Добрый день, Эдуард! В продолжении нашего вчерашнего разговора с проблемой сетевого рендера. Вот мы взяли с вашего сайта вот это дерево Matsu tree 1 от сюда https://exlevel.com/PlantsLibrary/#prettyPhotoи та же проблема на локальном компьютере рендер идет но только запускаем на рендер ферму все ступор , 3дмакс скушал 1,5 Гб памяти и все и компьютеры не чего не делают и не ругаются, Может что-то делаем по другому.

 

Добрый день! Т.е. на локальном компьютере все нормально? А только на ферме ступор, я правильно понял?

Link to comment
Share on other sites

Да Вы правильно поняли

Хорошо, тогда мы попробуем снова запустить сетевой рендеринг именно этого дерева, и посмотреть, что происходит на нодах...

А с другими моделями все нормально?

Link to comment
Share on other sites

sorry that you´re having these problems. Are you sure that you are using the latest version of 

our models and the latest version of Forest Pack Pro ?

I'm using the 5.0.5 version of ForestPack

 

Are the bitmaps all located at the correct place with access from your rendernode ? 

All images are placed on the server, and the address for images is on the server. But textures no problem 

 

Does the second message mean you have the same problem on your local computer as well ?

Local computer renders Xeon E5-2670, But this computer as a node gives out a black screen of 2 GB of RAM and the render job hangs

 

What exactly do you mean with "groan in a stupor" ? Your computer does not render anything

or it takes very long ?

I send the picture to the renderer through (Batskburner) computers are connected for rendering. And the render does not start the framebuffer window with the black screen, processor loaded on 0 and 1 - 2GB of operative memory nothing happens

When I transfer all the trees to Editable mesh Render Node starting render

A question how it is possible to make with the GrowFx animated mesh? Images https://www.dropbox.com/s/2db1s1dlivv2g71/Error_new.jpg?dl=0
Link to comment
Share on other sites

Большая часть проблем с елками Нам нужно засадить елки на большой территории и анимировать их. Объем примерно как горы Карпаты 3 Горы в ракурсе.

 

Хорошо, все ясно. Тогда я думаю завтра, мы попробуем протестировать сетевой рендеринг...

Link to comment
Share on other sites

Добрый день, Эдуард! Есть какие-то рекомендации.

 

Добрый день! В общем пока еще ничего не ясно. Мы все еще пытаемся изучить эту проблему.

Как будет что известно, я сразу сообщу.

Link to comment
Share on other sites

  • 3 weeks later...

Добрый день, Эдуард! Есть какие-то рекомендации.

 

Добрый день! Ну, так ничего и не получилось понять.

Вы не обращались к разработчикам Короны? Может они со своей стороны что-то найдут. Хотя бы понять где происходит остановка, и почему...

Давайте, сегодня мы еще кое что проверим, и если ничего не будет ясно, то тогда уже будем им писать...

Link to comment
Share on other sites

Добрый день, Эдуард! Есть какие-то рекомендации.

 

Добрый день!

 

Кажется мы нашли причину проблемы...
 
Все оказалось довольно банально. В общем, так как у Вас на некоторых деревьях не применен Vertex Color, а мап-карты VertexColor назначены в материалах этих деревьев, то система в начале рендеринга выдает предупреждение, и ждет пока пользователь примет решение о продолжении рендеринга. Я это обнаружил когда отключил корону, т.е. назначил обычный Scanline renderer, и запустил рендеринг обычном образом. На рендер-ноде этот диалог почему-то не показывается, т.е. при запуске через backburner, нода ничего не выдала и была в зависшем состоянии. Но когда я назначил стандартный материал на все деревья, т.е. убрал со всех деревьев карту VertexColor, то все сразу заработало, нода начала рендеринг, и успешно сохраняла картинки!
С короной пока проверить не получилось, но Вы можете сами это сделать...
 
В общем, проверяйте все деревья, и смотрите чтобы был настроен Vertex Color там, где это необходимо, или удаляйте map карты Vertex Color в материалах.
 
Кстати, еще было предупреждение о нехватке каких-то текстур, тоже как вариант зависания ноды, хотя я не знаю, возможно Вы мне не все прислали, и у Вас эти текстуры имеются...
 
С уважением,
Эдуард
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...