Jump to content
GrowFxUser

Meta Mesh's "stop stich" doesn't work as expected

Recommended Posts

Hi all,

I was experimenting some new stuff with meta mesh as I ran into this issue. Basically I have a tree with a trunk with two level branches.

Here's the settings for meta mesh of the trunk.

post-608-0-65642000-1423208703_thumb.jpg

And here's the meta mesh settings of the level 1 branches.

post-608-0-94548200-1423208772_thumb.jpg

Level 2 has a meta mesh without any stop stitching defined.

And here's the result that I get.

post-608-0-66776200-1423208991_thumb.jpg

Based on documentation and examples provided I guess this shouldn't happen. Why is it that the trunk is still stitching above the 10% that I defined.

(Areas in red circle)

Also, why is it that the level 1 branches have stopped growing after 20% instead of just avoiding stitching? (Blue question marks)

I'd appreciate any help.

Thank you,

Ashkan

 

Share this post


Link to post
Share on other sites

Hi Ashkan,

 

Thanks for the file!

 

I advise you to remove the texture from the Surface displace map for Branches_L1 -> Meta_mesh_03, or turn off the Stop stitching.
If Surface displace map is defined, metamesh will continue to stitching in independence of the Stop stitching settings.
 
Later, we'll try to fix this defect.
 
Cheers

Share this post


Link to post
Share on other sites

Thank you so much Eduard for your prompt reply.

It's O.K. , we'll wait for a fix whenever ready, but for now I'll stick to cylindrical mesh instead, since I need that displacement ;)

Thank you again for providing such a great support.

Share this post


Link to post
Share on other sites

By the way, removing displacement did the trick for L1 branches, however it doesn't do it for the trunk. 

If I go by after position, it doesn't respect the value at all.

post-608-0-26508600-1423238469_thumb.jpg

If I use by radius it splits the surface to two. 

post-608-0-00977200-1423238357_thumb.jpg

So just wanted to mention that the issue goes beyond the displacement I guess.

Here's the simplified file just in case :

Test03.max

Thank you again,

Ashkan

Share this post


Link to post
Share on other sites

Hi Ashkan,

 

We've fixed this bug. Also we've added a new option Stop stitching for children.

If you want to try it, please let me know...

 

Thanks for your bug report!

Share this post


Link to post
Share on other sites

Hi Eduard,

Thank you so much. It would be great if I could use the patched version. Btw, does it also include the fix for instanced geometry issue? Since in the previous version the instanced geometry's "pick randomly" didn't work as expected.

Thank you,

Ashkan

Share this post


Link to post
Share on other sites

Btw, does it also include the fix for instanced geometry issue? Since in the previous version the instanced geometry's "pick randomly" didn't work as expected.

 

Not yet, we just fixed the bug where you show as splits the surface to two, on your second screenshot...

Share this post


Link to post
Share on other sites

Thank you, I got the file.

I just had a question : 

 

"Now you can control the stitching "by Radius" only"

Does that mean I should use "Stop Stitching" > "By radius" ? Because I can see that It also works as expected even when using "After Pos. % " I can't see any problem there.

I should also mention that "Stop stitching for children" is absolutely amazing and a huge time saver.

Share this post


Link to post
Share on other sites

Does that mean I should use "Stop Stitching" > "By radius" ? Because I can see that It also works as expected even when using "After Pos. % " I can't see any problem there.

Sorry for the confusion. I mean, that it's enough to use "By Radius", but you can also use the "after pos. %".

 

Also, is it right that the stop stitching doesn't work for the trunk at all, yet? Regardless of using either"by radius" or "after pos. %" ?

As I said before, if the branches grow very dense, MetaMesh can't stop stitching until enough space between the branches.
So the Stop stitching works everywhere, but don't always have the conditions for it.
 
Thanks!

Share this post


Link to post
Share on other sites

 

As I said before, if the branches grow very dense, MetaMesh can't stop stitching until enough space between the branches.
So the Stop stitching works everywhere, but don't always have the conditions for it.

Now I got it. Thank you so much for all your support :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...