Jump to content

itoo forest doesnt work with growfx cache


Recommended Posts

HI,

When you cache out tree and try to add them to itoo forest they are just not there. Cache must be off. Also caching out to one file never works.  To one file per frame sometimes works with itoo sometimes doesnt  Thanks

 

And one more thing when having lots of plants in the scene  it takes a while to load max.  Grow fx has to make all these paths, etc. I wish it would do it faster. And I think these slow downs make our octane process geometry each frame over a minute if we have animated trees

Link to post
Share on other sites

You could try adding a point cache modifier in the stack instead of using the internal grow FX point cache. It has been a long time since I tried this but that is how I did it and it worked well.

 

I think That there is an option to turn off build on startup, but I can't remember how it is done. I checked the manual and didn't see anything. I think it has been discussed on the forum. I will look around and see if I can find anything.  

 

If your plants are rebuilding per frame you might have a animated plant that is rebuilding its meta mesh each time it moves. Make sure your wind modifiers are applied as "after mesh" modifiers. Also, if your plants are rebuilding each frame you are going to have trouble with your point cache because the vertex count is changing.

 

I hope this helps. 

 

 

 

 

  • Like 1
Link to post
Share on other sites

Ok, it looks like when a new scene is opened  all animated tree disappear from itoo.

How to reproduce the bug:

1. Cache animated tree,

2 Add them as custom object to itoo

3. save the scene and exit max.

4. Open the scene and you'll see itoo doesn't have trees in the scene anymore like they disappeared.

5. Open itoo and delete all custom objects and readd trees again. (sometimes uncheck Cache on readd trees and then reenable cache)

Link to post
Share on other sites

do all of your uncached plants give you the same issue, or is it just your cached plants?

 

Also, are you using meta mesh? If you are using meta mesh, is yourwind animation modifier an after mesh modifier?

 

Itoosoft does this to me as well sometimes but I can usually get my plants back by bumping the time slider up a frame, or rendering a single frame. I have never figured out why this occurs.  

Link to post
Share on other sites

So I did did a quick test. I am using an older version of itoosoft but I didn't see an option to load a cached animation file. When you say cache are you just talking about the vertex animation file or do you mean something else ? 

 

When I brought in the animated tree nothing showed up but then I moved the timeline forward a few frames and everything appeared again. 

 

 

 

 

Link to post
Share on other sites

Thank you! I'll send the scene soon. Also itoo random samples do nothing. All trees move at the same time  Thanks

 

PS It would be nice if exlevel can add  one push wind presets. Like smooth slow waving trees, fast moving etc. A lot of the time trees vibrate and dont move and we tried to tweak a lot

Link to post
Share on other sites

like this(bellow) in manual doesn't help at all  We need video samples like phoenix fd has. Speed isze. Well how will we know what it is. Tweak and then cache and tweak and cache for hours.  Give examples please

 

Perturb Speed group

Allows to control the parameters of turbulence in the velocity, giving the fractal noise to the speed. As a result, the wind speed at different points of space varies.

On

This checkbox enables this turbulence mode, and, accordingly, these parameters become available:

Speed Amount

Specifies the maximum speed deviation.

Size

Specifies the size of fractal noise.

Iterations

Controls the number of iterations (or octaves) used by the fractal function. Fewer iterations use less fractal energy and generate a smoother effect. An iteration of 1 is the same as turning Fractal off. Range=1 to 10. Default=1.

Link to post
Share on other sites
On 10/20/2020 at 5:49 PM, cb2000 said:

Ok, it looks like when a new scene is opened  all animated tree disappear from itoo.

How to reproduce the bug:

1. Cache animated tree,

2 Add them as custom object to itoo

3. save the scene and exit max.

4. Open the scene and you'll see itoo doesn't have trees in the scene anymore like they disappeared.

5. Open itoo and delete all custom objects and readd trees again. (sometimes uncheck Cache on readd trees and then reenable cache)

 

just did a small test & everything was working with no errors (forrest --> animation->follow Geometry used)

in my test i cached everything to 1 file

 

about wind, i would use the ereaser direction modifier in each path to simplify your tree for faster simulation time

when everything looks fine , just disable it and test the whole tree

do not forget to animate the Phase!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...